Contact Info

Crumbtrail

ActiveXperts.com » ActiveSocket » Release Notes » ActiveSocket 2.4

ACTIVESOCKET 2.4 RELEASE NOTES

INTRODUCTION

ActiveSocket 2.4 is the newest version of the ActiveSocket Network Communication Toolkit.
The mission of the product is to provide a collection of useful network communication tools for a variety of development platforms.

WHAT'S NEW IN ACTIVESOCKET 2.4

- Error Codes -

  • ActiveSocket now uses universal ActiveXperts Error Codes. As a result, all error codes values have changed. You can now go to the ActiveXperts web site to lookup an error code, no matter which ActiveXperts product generated the error. Use the following URL: www.activexperts.com/support/errorcodes, or use the GetErrorDescription function of any of the toolkit objects.

- Constants -

  • In previous versions of ActiveSocket, constants where defined in include files. Each demo project had a constant file which allowed the user to use constants in a project. In version 2.4, these constants files do not exist anymore. Instead, constants are defined as read-only properties of the object(s).

INSTALLATION AND UPGRADE

- Installation -

To learn more about installing the product for the first time, please read our manual. You can download the manual at www.activexperts.com/files/network-component/manual.htm

- Upgrade from ActiveSocket 2.3 -

Upgrade to ActiveSocket 2.4 in the following way:

  • Uninstall the ActiveSocket 2.3 product. Use the 'Add/Remove Programs' applet in the Control Panel to start the Uninstall procedure;
  • Download the ActiveSocket 2.4 Installation file from the ActiveXperts Software web site: www.activexperts.com/download;
  • Start the ActiveSocket 2.4 Installation. The InstallShield wizard will guide you through the steps of the installation.

- Upgrade from ActiveSocket 2.2 of older versions -

Registered users of ActiveSocket should read the ActiveSocket 2.2 Upgrade Notes before you upgrade to version 2.4 As a registered user, you must use the new registration code that was sent to you by ActiveXperts Software. ActiveSocket 2.2 registration codes (or older) will not work anymore. Upgrade to ActiveSocket 2.4 in the following way:

  • Uninstall the ActiveSocket 2.x product. Use the 'Add/Remove Programs' applet in the Control Panel to start the Uninstall procedure;
  • Download the ActiveSocket 2.4 Installation file from the ActiveXperts Software web site: www.activexperts.com/download;
  • Start the ActiveSocket 2.4 Installation. The InstallShield wizard will guide you through the steps of the installation.